PDA

View Full Version : SLGK-160 Buggy Info - GY6 Manuals And Wiring Diagrams


JakeTheSnake
03-30-2010, 10:46 PM
Hey All,
Here's all the techs, specs, manuals, parts lists and pics for my mini-buggy the SunL SLGK-160. I have tons of other manuals for basic buggy 101 stuff, and other manuals many other brands of 150cc buggies. Hit me up for any info!

BuggyMaster
03-30-2010, 11:38 PM
Nice job! I'm going to retitle and make a sticky out of this!

nathan
04-21-2010, 02:57 PM
thanks for the manuals

cochranlance
05-17-2010, 04:27 PM
thanks for the manuals

Danny
06-23-2010, 10:06 PM
Nice job! I'm going to retitle and make a sticky out of this!

i have a slgk 160 and it quit pulling can u tell me what might be wrong with it

BuggyMaster
06-23-2010, 10:46 PM
Well, what do you mean when you say it quit pulling? When you step on the gas it won't go anywhere?

nathan
07-22-2010, 04:32 PM
hey i have a slgk 160 but i have a problem i have to unplug and drain the fuel filter and plug it back in to start it could you help me

Zipsplat
09-04-2010, 11:11 PM
I've been looking everywhere for this info. Thank you!

Deke101
09-16-2010, 01:00 PM
OMG! I have been looking for this info for WEEKS! THANKS!

bshawn602
09-28-2010, 10:01 PM
Well, what do you mean when you say it quit pulling? When you step on the gas it won't go anywhere?

I am experiencing no movement when pressing on the gas in forward or reverse. I just purchased a Kinroad 150cc Dust Devil buggy that was working fine until last night. While driving the buggy, it disengaged and would not go forward or reverse. I checked all the cable connections and there is no sign of slack or disconnection.

Dachshund
10-24-2010, 08:26 PM
Thanks for the manuals Jake the Snake.

turnouts
11-07-2010, 09:27 PM
I purchased an after market GY6 engine to replace the engine on a chinese scooter, but the wire colors and connectors do not match those on my scooter. What can I do?

cymbaline
11-24-2010, 09:57 AM
Hey All,
Here's all the techs, specs, manuals, parts lists and pics for my mini-buggy the SunL SLGK-160. I have tons of other manuals for basic buggy 101 stuff, and other manuals many other brands of 150cc buggies. Hit me up for any info!

I'm new here, and just wanted to thank you for this thread... :biggthumpup:

My son's buggy, which appears to be identical to yours, yet has been a nightmare for me to keep running since we bought it this past Spring for his birthday... :banghead: Our's came from Sunny Sports in Chino, CA. http://www.scooterdepot.us/product.php?productid=427

With that said, I might become a pest for information/help in the near future... LOL

Thanks again...
-John

SYCARMS
11-24-2010, 10:12 AM
Danny check the drive belt under the cvt cover.
Nathan check your fuel cap vent, Try with cap loose if problem goes away its the cap

Tom

SYCARMS
11-24-2010, 10:13 AM
Cymbaline just ask away, thats what were here for

Tom

jpman
12-19-2010, 12:59 AM
Good job Jake!

dashley
06-14-2011, 07:51 PM
hey might you have the manual for a sunl 150cc kart, thanks Jake

SYCARMS
06-14-2011, 08:38 PM
Scroll up this thread to the first post. Jake the Snake has several sunl pdf files you can download.
Tom

JakeTheSnake
06-15-2011, 05:44 AM
Yep, like Tom said, up top you'll find all things 150cc SunL. If you have a different type of SunL buggy be a lil' more specific and I'll see what I can do.

renovator62
06-20-2011, 04:32 PM
to begin with id like to thank u guys for this site. its been helpful already. Anyhow to my situation....I have a roketa GK-01 dune buggy that i have recently come across and someone has screwed the wiring up on it,so im in search of the wiring diagram for it. I know the coil is bad it was gone when i got the buggy. Id really appreciate any help that i can get with the wiring. all i really need is the diagram and color codes from the stator to the starter.Thanks in advance ...

ekul
07-11-2011, 10:12 PM
Hey All,
Here's all the techs, specs, manuals, parts lists and pics for my mini-buggy the SunL SLGK-160. I have tons of other manuals for basic buggy 101 stuff, and other manuals many other brands of 150cc buggies. Hit me up for any info!

just what i needed.thanks bunch

renovator62
07-15-2011, 01:07 PM
Thanks man. That helped alot....

bsoutlaw
08-31-2011, 12:58 AM
Ijust bought a sunl 150r and in low band it jerks about every 10 seconds or so... what could that be? Thanx

SYCARMS
08-31-2011, 01:31 AM
What about top speed, does it jerk?

TOM

bsoutlaw
09-01-2011, 03:19 AM
No, only in the lower gear, and at higher rpm.

SYCARMS
09-01-2011, 05:41 PM
Make sure you have good fuel, if it don't smell like fresh fuel like out of the pump in last few days replace it. If buggy sat for some time with fuel in it (2-3 weeks) drain tank pull carb and clean. Check the 2 wires at coil making sure they are secure. Pull spark plug and read. Depending on your location google non ethanol fuel with your zip and any nearby zips to see if it is available, if so use it cause you will eliminate future problems.

TOM

metalstudman1
09-01-2011, 08:22 PM
CVT could be suspect also

brendan
11-06-2011, 03:39 AM
Hi i am busy fixing a Kazuma SLGK-150 buggy and i just wanted to know where can i get a wiring diagram for it

flying
01-02-2012, 10:11 PM
Is this the same as the baja reaction br-150 L4V? I am having engine and transmission problems.

98smallengine
01-03-2012, 05:18 PM
Hello, David here,from 98 Small Engine,we recently replaced a gy6 150 on a Yerf Dog with a generic one from Ebay. The electrical plugs don't match from the old engine to the new engine,ie. cdi,voltage reg. ect. does anyone have any suggestions. Thanks David

SYCARMS
01-03-2012, 06:09 PM
This is one of the problems with engines over the internet. Many of the sellers have no clue what they are selling, only that it is a gy6. Their are several different manufactures that wired their particular buggy depending on how they seemed fit to wire it to the acessories that were on the buggy. The Yerf was a basic wiring since except for headlights they came with no acessories. You will have to rewire the motor to adapt. We will need much more info such as how many pole is the stator what color and how many wires come off the stator. Usually the stator has one plug with anywhere from 3-5 wires and I have seen some with more and 2 seperate wires with bullit connectors. The main plug is for the charging only where the 2 single with bullit connectors are for the ignition and should match up with current wiring. Connecting just the 2 single wires will enable the engine to run, but it will not charge unless the new engine is wired fior a DC cdi vs. the yerfs stock AC cdi. Let us have more info with some good pics. Remember we cannot see what you are looking at so accurate info and pics are necessary.

TOM

98smallengine
01-05-2012, 10:37 AM
Hello Tom, Thanks for the quick reply,hope the picyures get thru,http://Buggy Windows Photo Gallery image 074 thru image 103

SYCARMS
01-05-2012, 04:32 PM
I cannot open

98smallengine
01-09-2012, 12:19 PM
Hello Tom, I'm having problems with Comcast, will send some pictures when I can.
Thanks again, David

SYCARMS
01-09-2012, 01:48 PM
Well don't feel alone cause I constantly have problems with AT&T. Once upon a time in America you had choice, now these corporations either buy up or put out of business the competition. I was trying to get Comcast here at the shop but I learn from the people who have their service that their no different then AT&T.

TOM

98smallengine
01-10-2012, 03:53 PM
Hi Tom, Thanks for the quick reply, I'm still trying to send pics. I know what you mean about big business wanting it all. This time the we are happy to make expenses. Thanks again , David

paul cornwall
01-16-2012, 10:51 AM
hi jake do you have any info at all for a kinroad xt 250gk-2 igot this recently for my son but deperately needs some attention any info at all would be great especially a wiring diagram

jahrac
03-10-2012, 11:29 PM
can u tell me if the wiring diagram in gy6 engine manuel will work with a roketa gk-01. i bought a gy6 motor on ebay this is the motor on the ebay site http://www.ebay.com/itm/150CC-GY6-SCOOTER-ATV-GO-KART-ENGINE-MOTOR-150-CVT-AUTO-CARB-PACKAGE-SHORT-CASE-/200704430226?pt=Motorcycles_Parts_Accessories&hash=item2ebaea9092&vxp=mtr

SYCARMS
03-11-2012, 12:24 AM
Depends what stator is in the engne.

TOM

bLudbrother
03-24-2012, 07:48 PM
I am new here, and man I am glad I found this site! I bought the kids a Yurf-dog 150cc buggy. I got it pretty cheap from a buddy. I am pretty mechanically inclined but i am stumped on this thing... Here is whats going on... The machine has new gas, fuel filter, spark plug, air filter and a new carb with auto elec choke . The machine will not start unless i place my hand over the air box connection inlet. I am thinking the choke is my issue or a vacuum problem. the hoses were all off the carb when i got this thing does any have a vacuum routing diagram?

SYCARMS
03-24-2012, 08:36 PM
Not sure if you have the vacume operated fuel pump or just a strait petcock. If you have the fuel pump you will know since it will have two lines going to it at the bottom of the fuel tank. If so the top line goes to fuel and the bottom goes to vacume. Some carbs have on the right side just forward the throttle an air bleed valve. Vacume will go to it, then it will tee to the pump. Have you adjusted the valves yet, or checked compression? Compression should be no lower then 130psi and valves should be set accordenly, cold, Intake @ .003" and Exhaust @ .005". Either low compression or too tight valves will cause this hard starting. Ideal compression should be 150psi. If the compression is good and valves adjusted correctly then check for a vacume leak @ the intake. The intake could be cracked or the plastic isolator under neath, also you could have a cracked o-ring which seals the intake.

domomike
05-07-2012, 02:51 PM
I have to put my fingover the intake like a choke to get mine to start. I just picked it up from one of my customers i delivered water to. . Any ideasi

SYCARMS
05-07-2012, 02:58 PM
Whats the compression? Have the valves been adjusted, have you checked for vacume leaks?

domomike
05-07-2012, 03:02 PM
Not yet. I was going to start by cleaning the carb since it sat outside

SYCARMS
05-07-2012, 04:48 PM
Its best to get the carb dip to clean the carb in. Much of the time the gummout don't work esprcially getting into all the orifices. Also you don't want to use anything but compressed air to clean the pilot jet if blocked since it will enlarge the hole. Cleanning is the first thing you want to do but checking the other as I suggested will give you an idea of what condition the motor is in. Misadjusted valves or low compression will affect how it runs and performs,and will help greatly if more trouble shooting should be needed. Not knowing those things will make diagnosing hard and inaccurate.

TOM
,

TOM

domomike
05-07-2012, 05:04 PM
Thanks.

domomike
05-07-2012, 07:54 PM
Where can i find where all the air lines go. Have some that got melted and some that was not connected.

domomike
05-07-2012, 08:57 PM
There are vacuum lune here and there. On the carb there are places for lines but have no idea where they go. Any help?

SYCARMS
05-07-2012, 11:03 PM
First you need to determine if you have a manual petcock with shut off valve or a vacume operated fuel pump. Look under the fueltank for this. If you have 2 lines comming from the tank then you have a vacume operated fuel pump. The top hose goes to the carb fuel feed line the bottom goes to vacume off manifold. If you have a manual petcock off the tank or just a fuel nipple then disreguard the vacume to tank. On the right side of the carb just forward the throttle linkage there is an air bleed which most cvk carbs use an external vacume source which will require vacume to it. If both the tank and airbleed are supplied with vacume then vacume comes off the intake manifold and using a vacume T to route one hose to pump and other to air bleed. The hose off top of valve cover is just routed toward back of engine for this is the crankcase vent hose. There is a short turn down hose on right of carb this is a fuel bowl vent then there is a hose off the bottom of fuel bowl this is just for draining the fuel bowl.

ellamyrona
05-08-2012, 04:29 AM
There is along time since i'm searching for these manuals and it's great to find them here. I have to recognize you have done a great job by adding these attachements here and making themgo kart for sale (http://www.mygokarts.com/go-karts.html)available for all peopel around.

domomike
05-08-2012, 05:02 PM
Ok i looked at the tank today. Looks like someone welded a nipple so its a straight gas line to the carb. Do i need to put in a manual fuel pump? And if you are at the back of the gokart on the left side of the carb the is another inlet near the top. I seen a pic of one that says where all the line should go but it shows nothing for this inlet on the carb. It right in front of the electronic choke. I may just by a ne carb. Seen them new for 30$. Thanks for all the help.

metalstudman1
05-08-2012, 07:11 PM
Post a pic of your carb-Most carbs are the same. Looking at the carb from the rear (throttle on the right, FEV on the left) Main fuel inlet is just in front & below of the FEV-usually a brass nipple. Just behind the FEV up high is a vent/overflow nipple- goes to air. Just in front of throttle is the vacuum inlet- goes to intake, either directly or into a "T" that would go to a petcock valve at the tank. The idle screw is on the throttle apparatus. The fuel/air mix screw is behind a (usually brass colored) cap behind and below the FEV,pop/pry the cap to expose the screw. The bowl will have a fuel drain screw with a nipple- vent to air.

domomike
05-08-2012, 07:25 PM
Sorry to keep bugging. Just want to get this thing running. Ok on the muffler there is a outlet that runs over to another part, no idea what it is but there is a oulet on top of it and a lil outlet on the bottom . Also right above that part is a plastic part that has a outlet on bottom and on top. No clue

metalstudman1
05-08-2012, 07:34 PM
It's and EPA required EGR valve. plug it off completely( whatever you can find, they do sell rubber stoppers @ the autoparts store)!!! It had to be installed to meet emission requirements and it doesn't help or hurt the proper running of the engine. I cut the steel tube off @ the pipe and weld a plug over it!!

domomike
05-08-2012, 07:42 PM
Thanks thats some good news.

domomike
05-10-2012, 08:55 PM
Ok i got it to run today fairly well. But as i try to put it forward i hear a grinding sound when it in-gauges the cart plunges forward and stalls. When i put in reverse its not as bad of a sound but still stalls out. The man i got it from said the chain broke and he took it to get a new one put on. But when he got it back it goes faster in reverse than in forward.

SYCARMS
05-10-2012, 10:49 PM
Its normal for the buggy to seem to go faster in reverse since the gear ratio of the reverse unit holds it in low gear. It was that way before he put the new chain on. You first have to determine where the grinding is comming from. It could be from the reverse box due to the gears not meshing at first then slamming into gear. This can be a simple cable adjustment but you need to determine carefully where the grinding is from before tearing anything up then worry about the dieing engine later. The guy you bought it off probably did not tell you all thats wrong this is generally why people sell them when they are not running . Most common story I hear from 70% of customers who bought non running buggies is : it run great before it sat but now the kids don't drive it and it sat up and now won't start. Since you cannot start it and drive it you have bought a mystery buggy and can count on something else wrong 70% of the time. Good news is nothing costs that much to fix as compared to say a Honda or like unless you have an off the wall brand that parts are no longer available. Lesson to learn here is if it don't run even if there only asking 300.00 offer 100.00 unles they get it running. What brand of buggy is it? If unknown post some pictures for it will deffinately help should you need parts. Also where are you located?

TOM

domomike
05-11-2012, 12:12 PM
Sound like the noise is coming from the cvt, i think thats what its called. My friend from work has a go kart similar to mine and said the more is reved his grinds also. So is mine reved to high? Or could the clutch be stuck? I can email you some pics of my kart im on my phone and it wont let me paste a pic. Yesterday i took apart where the shist cable goes near the chain but it all looked fine no shavings, or wear. Plenty of grease.

SYCARMS
05-11-2012, 02:52 PM
There should not be a grinding noise. The only thing you can do is to pull the cvt cover and inspect all components for any unusual wear or breakage. It is impossible for anyone to trouble shoot with such a general description. If your not sure about weather something looks normal or not take a pic and post it of the part in question. The more information we have the better we can pinpoint your problem. Put the buggy on jack stands and operate it while looking and listening for where the noise is comming from or anything that appears abnormal. Once you pinpoint the area then visually inspect it. Post the info.

TOM

domomike
05-11-2012, 07:57 PM
Ok sorry for so many questions. I took off the gear box where the shift cable goes too. And i started the gokart and the grinding stoped as it was running with this off. I was looking at the gearbox and when in reverse it seems to lock and i turn it by hand. Same thing for forward. Do i need a new one. I have pictures but cant post them. I can email u some of the part and gokart. But if u look up at jackthe snakes its the same as mine just black.

domomike
05-11-2012, 08:18 PM
cant turn it

SYCARMS
05-12-2012, 05:21 AM
If you have the reverse box off just split it and look to see what the problem is. All it consists of is a fork with spring spacer and planetary gear. If you post some pics of the box. Not sure how to do it from a phone but if you download the pics to your computer click on manage attachments, another window will pop up click browse then select the file you have your picture in then click upload. I can then see which type of cable tower you have and instruct you how to disassemble if you should have trouble, but once the rev. box is off the case should just split but you have to remove the cable first.

domomike
05-12-2012, 09:21 AM
How do i remove the cable on the gear box. I cant seem to get it off

SYCARMS
05-12-2012, 10:41 AM
I could tell you for sure if I had a pic of the unit.

domomike
05-12-2012, 01:49 PM
here is a pic of the gear box off the cart

SYCARMS
05-13-2012, 01:00 PM
Where is the final shaft that runs thru the center of the rev. unit? Unless you have cleaned it, it appears to lack grease/

domomike
05-13-2012, 01:09 PM
The rest is still on the cart. The chain is on it. I havent cleaned it so i will pick up so grease for it whats a good type?

SYCARMS
05-13-2012, 07:59 PM
The pic kinda looked like the rev. unit was still on the engine. Any good quality bearing grease is fine. I prefer Valvoline lithium moly wheel bearing grease. Comes in a Dk. Blue can. Autozone carries it. You want a liberal amount of grease in it but not to over do it. All gears will be totallt covered with about 1/8" covering the inner body. Clean it really good then inspect the gears for wear and the 3 planitary gears for excessive bearing wear.

domomike
05-15-2012, 08:01 AM
Ok i cleaned and put new grease on the rev. It did help. But when i put it in forward or reverse if slams into gear and stalls. Almost like the clutch is engaged. Shouldn't it just sit there till i give it gas. Any help. Thanks alot

SYCARMS
05-15-2012, 10:27 AM
There should not be a grinding noise. The only thing you can do is to pull the cvt cover and inspect all components for any unusual wear or breakage. It is impossible for anyone to trouble shoot with such a general description. If your not sure about weather something looks normal or not take a pic and post it of the part in question. The more information we have the better we can pinpoint your problem. Put the buggy on jack stands and operate it while looking and listening for where the noise is comming from or anything that appears abnormal. Once you pinpoint the area then visually inspect it. Post the info.

TOM

Yes it can be the clutch, bearing/bearings, shaft in final drive, any or all of these. But we cannot repair it for you we can only answer questions with the info and pics you post. Just by what looked to be barely any grease in the rev unit this buggy was sold with no presale prep and or, no maintenance by previous owner, but this is only my assumption from the one pic of the rev box. If you are unsure of how to disassemble something there are excellent manuals at the start of this thread which will pretty much give you the detailed information needed. Understand, I'm not trying to be difficult but your buggy is somewhere other then we are and we can neither see, hear or witness the operation of your buggy. You have to disassemble and inspect what we recommend then relay the info you discover to us. You may also need at times to post some pics for us to make a call. Put the buggy on stands, pull the cvt cover, inspect components, run on stands to see operation of components, and check the oil in the final drive. Let us know what you find. If you do these things your buggy will be running in no time.

TOM

gx150r
05-21-2012, 07:38 PM
just wondering if u had any info on a wiring a cdi box for talon gx150. any info would be great.

domomike
05-30-2012, 10:53 PM
Ok guys thanks alot for all the tips. Got a new carb and checked some more wires. And she starts up fine. All i need now is a clutch and im good to go. Now the hole lights being dim! I was looking at it today 053012 and there is a plug by the cdi box that has 4 wires going into it. Was looking at the manual and see that its the headlight relay. I jumped a wire from one of the ports to another a bamm the lights got brighter. Now the big? Is what kind of relay do i need for this.

SYCARMS
05-31-2012, 06:35 AM
If you can post some pics it would help identify what you are refering to. Carter may have used a relay in their later models. But I have never seen a relay used. The early carts that used the 4 and 6 pole stators would have dim lights at idle then would brighten as the rpm's increased. The lights get their power from the rectifier AC side.

SYCARMS
05-31-2012, 06:38 AM
just wondering if u had any info on a wiring a cdi box for talon gx150. any info would be great.

Sorry GX150r I have had some computer problems of late and had not seen your post. What kinda info are you looking for. Do you know if it is a ac or dc cdi?

domomike
05-31-2012, 08:38 AM
In one of the pdf's at the top of the post is the parts list. Its a yellow cart in the section that has the wireharness, horns, and other electrical parts there is a relay for the lights. I think it was number 26. The description says its the light relay. But i need to no what kind.

SYCARMS
05-31-2012, 09:04 AM
I see what your looking at but if you go to the circuit diagrahm it will show no light relay. As I said I have never seen any of these buggies with a light relay.

domomike
06-19-2012, 08:19 PM
ok got my spider 150cc running new clutch and carb. starts fine and runs ok. now i have another problem. when i put it in foward it hardly moves like .000001 mph lol. but when i put it in reverse it moves great and kindda fast. what could cause this? any help would be great.

domomike
06-24-2012, 05:27 PM
any ideas on my post? realy want to start driving this thing

WoodChuck_08
08-20-2012, 02:36 PM
Hey All,
Here's all the techs, specs, manuals, parts lists and pics for my mini-buggy the SunL SLGK-160. I have tons of other manuals for basic buggy 101 stuff, and other manuals many other brands of 150cc buggies. Hit me up for any info!

Thank you for the repair manual. Hope it helps fix this piece of .... It's been thrown in the corner of the shop for all summer. Had to be towed in with the fourwheeler..

Thank you

JavaPatriot
10-09-2012, 09:31 AM
Hey guys, just downloaded the engine service manual for the GY6. I have the gk-01 or SLGK-110, or gk-17 depending on where you look. It is the 110cc version of these chinese go karts. Bought it with the wiring harness destroyed! Guys dog ate it! He explained that it was parked near the dog after the stator went bad. I opened it up and the stator and flywheel trigger has a LOT of rust on it's mounting points. I wonder very much if it had not just lost it's ground and therefore spark.

Anyway, I guess my question is: Does the GY6 manual work for the 110cc as well? Obviously wire color code is important here as are electrical parameters. It looks to me that they are giving info for the full wave stator, and these are only a half wave.

ANY info is appreciated.

SYCARMS
10-09-2012, 01:47 PM
No, two different engines nothing alike.

bear
10-10-2012, 12:48 PM
I think u can get the schematic @ roketa.com?

twaysrus
11-26-2012, 09:52 AM
I am in the process of converting a go kart over from a 90cc two stroke to a 150cc four stroke both GY6 engines. I could really use help with I dentifying what these components are so I know how to wire this thing back up.

BuggyMaster
11-26-2012, 09:57 AM
90cc two stroke on a go cart/ buggy? That's how it came?

twaysrus
11-27-2012, 12:00 PM
Yes that's how I got it. It had a Linhai 90CC two stroke on it. I have installed the 150CC with a few modifications to the mounting brackets. I did get it running so now all I have to do is finish the exhaust mods.

Sweeperman
02-08-2013, 08:43 PM
I need some kind of wiring diagram with color of wires to show me where all these wires go, someone has just pulled all wiring apart and have no idea where it all goes. If anyone has any idea please!! help and thanks in advance and i have checked all the diagrams above and none has any color codes

SYCARMS
02-08-2013, 08:46 PM
What buggy do you have ? There are all kinds of schematics.

kerryd
06-11-2013, 10:44 AM
Hey. Just wondering if you have any manuals for the carbide 150 cc buggy. I recently bought one the is missing some parts. I also need a wiring diagram if you've got one. I'm new to this site and to these buggies so any info will be greatly appreciated. I also need a link on where I can get replacement stuff,like seats,tires,etc. The parts missing are on the right side where the sprocket is supposed to b tranny parts I think. Thanks.

SYCARMS
06-11-2013, 10:55 AM
All manuals can be downloaded off the American Sportworks web site. I can get the parts for you with 20% off what ASW would charge.

TOM

BuggyMaster
06-11-2013, 11:01 AM
Actually I have the manuals here on this web site as well.

http://www.buggymasters.com/forum/forumdisplay.php?f=7

kerryd
06-11-2013, 11:21 AM
thanks for the help guys. I'll definitely be getting some parts. The people that had it took apart the tranny right above the axle and couldn't remember what they did with the parts. Duh. Anyway thanks for the quick replies.

kerryd
06-11-2013, 11:57 AM
Thanks,Tom. I'll be getting a list together.

kerryd
06-11-2013, 09:35 PM
All manuals can be downloaded off the American Sportworks web site. I can get the parts for you with 20% off what ASW would charge.

TOM

Ok,Tom.I've got a list and quite a list.LOL. From section 4(transmission),page 5 of the carbide parts list;1 of everything.A 14562 kit,14563 kit,and 14564 kit.14192,14195,14200,14201,14484.This is what I think I need. if you can give me a price we'll go from there.Thanks.

SYCARMS
06-17-2013, 05:01 AM
Sorry for not getting back sooner, I went to clear my spam but always check it first and found this in it. I will get you some prices later today.

TOM

kerryd
06-17-2013, 07:41 AM
Ok,Tom.I've got a list and quite a list.LOL. From section 4(transmission),page 5 of the carbide parts list;1 of everything.A 14562 kit,14563 kit,and 14564 kit.14192,14195,14200,14201,14484.This is what I think I need. if you can give me a price we'll go from there.Thanks. .Ok. thanks.

gofaster
09-23-2013, 10:30 AM
Question
On my Trailmaster xrs 150 the fuse keeps blowing every time the key is turned on. Given that there are no bared wires touching the frame got any ideas as to why the fuses keep blowing?

SYCARMS
09-23-2013, 10:46 AM
You have a short somewhere. The ign switch gets it's power from that fuse. If when you turn the ign on and the fuse blows it's due to 12v going directly to ground. Check the hot coming from the ign. switch which powers the ignition system.

TOM

gofaster
09-23-2013, 11:17 AM
Thanks I will check the ignition switch wiring.

SYCARMS
09-23-2013, 11:57 AM
As I said the fuse supplies power to the ign. switch so that part of the circuit is fine it's the circuit going to the ignition system. It could be the switch. You can eliminate the switch by jumping the wire with 12v to the wire which runs to the ign. If when you jump the two which will simulate turning the switch on and if the fuse still blows it will eliminate the switch then you will trace the wire color which goes back to the ign system